LAB II ( Dual-Homed BGP, HSRP, Linkstate tracking )

Setup:

  • Dual-homed BGP between AS100 and AS200
  • AS100
    • HSRP 192.168.0.10 between R1 and R2
    • Router 1 HSRP Master
    • Linkstate tracking on Fa0/0
    • EIGRP as IGP
  • AS200
    • HSRP 10.10.10.10 between R3 and R4
    • Router 3 as HSRP Master
    • Linkstate tracking on Fa0/0
    • OSPF for IGP

Scenario: The link between Router1 and Router3 would fail. Linkstate tracking would decrement the HSRP priority and switch masters.

When the link was restored and using default HSRP timers, the HSRP master would switch back before the BGP session was established between Router1 and Router3 (at least in GNS3).
Setting up delay timers and linkstate tracking would allow for a good recovery.

 

 

Router1:

track 1 interface FastEthernet0/0 line-protocol

interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
 standby 10 ip 192.168.0.10
 standby 10 priority 120
 standby 10 preempt delay minimum 30 #HSRP DELAY SO BGP IS ESTABLISHED BEFORE HSRP MASTER CHANGE
 standby 10 track 1 decrement 50 #TRACKING FA0/0
!
router eigrp 100
 network 192.168.0.0
 auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.0.0
 neighbor 172.16.1.2 remote-as 200
 neighbor 192.168.0.2 remote-as 100
 no auto-summary
!
R1#sh standby
FastEthernet0/1 - Group 10
  State is Active
    2 state changes, last state change 00:01:11
  Virtual IP address is 192.168.0.10
  Active virtual MAC address is 0000.0c07.ac0a
    Local virtual MAC address is 0000.0c07.ac0a (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.140 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is 192.168.0.2, priority 100 (expires in 8.624 sec)
  Priority 120 (configured 120)
    Track object 1 state Up decrement 50
  IP redundancy name is "hsrp-Fa0/1-10" (default)
R1#
R1#sh bgp
R1#sh ip bgp sum
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 7, main routing table version 7
6 network entries using 702 bytes of memory
12 path entries using 624 bytes of memory
8/4 BGP path/bestpath attribute entries using 992 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2342 total bytes of memory
BGP activity 6/0 prefixes, 12/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.1.2      4   200       8       5        7    0    0 00:01:26        5
192.168.0.2     4   100       8       8        7    0    0 00:01:26        6
R1#

Add a Comment

Your email address will not be published. Required fields are marked *


CAPTCHA Image
Reload Image