LAB VIII: MPLS (MP-BGP – EoMPLS)

  • P Routers – Provider routers
    • MPLS Core
  • PE Routers – Provider Edge routers
    • MPLS – IP Edge
  • CE Routers – Customer Edge routers
    • IP Edge

Traceroute (R6 -> R7)

Layer 3 setup:

 

GNS3 LAB:

 

 

Setup and config:

  • R0 label range¬† 16¬† 99
    • First 15 are reserverd: https://www.iana.org/assignments/mpls-label-values/mpls-label-values.xml
  • R1 label range 100 199
  • R2 label range 200 299
  • R3 label range 300 399
  • R4 label range 400 499
  • R5 label range 500 599

 

P Router configs:

R0# router ospf 1
 network 10.255.0.0 0.0.0.255 area 0

interface Ethernet1/0
 ip address 10.255.0.1 255.255.255.252
 duplex full
 mpls ip
!
interface Loopback0
 ip address 1.0.0.1 255.255.255.0
 ip ospf 1 area 0
!

R0#sh ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.0.3.1           1   FULL/DR         00:00:36    10.255.0.26     Ethernet1/2
1.0.2.1           1   FULL/DR         00:00:31    10.255.0.10     Ethernet1/1
1.0.1.1           1   FULL/DR         00:00:31    10.255.0.2      Ethernet1/0
1.0.4.1           1   FULL/DR         00:00:34    10.255.0.102    FastEthernet0/0

R0#show mpls interfaces
Interface              IP            Tunnel   BGP Static Operational
FastEthernet0/0        Yes (ldp)     No       No  No     Yes
Ethernet1/0            Yes (ldp)     No       No  No     Yes
Ethernet1/1            Yes (ldp)     No       No  No     Yes
Ethernet1/2            Yes (ldp)     No       No  No     Yes

PE Router configs:

R4#
mpls label range 400 499

ip vrf CUST_A
 rd 65000:100
 route-target export 65000:100
 route-target import 65000:100

interface FastEthernet0/0
 ip vrf forwarding CUST_A
 ip address 10.255.100.1 255.255.255.0
 ip ospf 2 area 0

interface Ethernet1/0
 ip address 10.255.0.102 255.255.255.252
 duplex full
 mpls ip
!
interface Ethernet1/1
 ip address 10.255.0.106 255.255.255.252
 duplex full
 mpls ip

interface Loopback0
 ip address 1.0.4.1 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0

router ospf 2 vrf CUST_A
 router-id 10.255.100.1
 redistribute bgp 65000 subnets
!
router ospf 1
 network 10.255.0.0 0.0.0.255 area 0
!

router bgp 65000
 bgp log-neighbor-changes
 neighbor 1.0.5.1 remote-as 65000
 neighbor 1.0.5.1 update-source Loopback0
 !
 address-family vpnv4
  neighbor 1.0.5.1 activate
  neighbor 1.0.5.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf CUST_A
  redistribute ospf 2
 exit-address-family
R4#sh mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
400        No Label   l2ckt(1)         61973         Et1/3      point2point
401        No Label   1.0.2.1/32       0             Et1/1      10.255.0.105
402        16         1.0.1.1/32       0             Et1/0      10.255.0.101
           17         1.0.1.1/32       0             Et1/1      10.255.0.105
403        No Label   1.0.0.1/32       0             Et1/0      10.255.0.101
404        19         10.255.0.12/30   0             Et1/0      10.255.0.101
           23         10.255.0.12/30   0             Et1/1      10.255.0.105
405        17         10.255.0.200/30  0             Et1/0      10.255.0.101
           24         10.255.0.200/30  0             Et1/1      10.255.0.105
406        Pop Label  10.255.0.8/30    0             Et1/0      10.255.0.101
           Pop Label  10.255.0.8/30    0             Et1/1      10.255.0.105
407        Pop Label  10.255.0.4/30    0             Et1/1      10.255.0.105
408        Pop Label  10.255.0.28/30   0             Et1/1      10.255.0.105
409        Pop Label  10.255.0.0/30    0             Et1/0      10.255.0.101
410        Pop Label  10.255.0.24/30   0             Et1/0      10.255.0.101
411        20         1.0.3.1/32       0             Et1/0      10.255.0.101
           16         1.0.3.1/32       0             Et1/1      10.255.0.105
412        22         1.0.5.0/24       0             Et1/0      10.255.0.101
           26         1.0.5.0/24       0             Et1/1      10.255.0.105
413        25         10.255.0.204/30  0             Et1/0      10.255.0.101
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
           19         10.255.0.204/30  0             Et1/1      10.255.0.105
414        No Label   10.255.100.0/24[V]   \
                                       1872          aggregate/CUST_A
415        No Label   172.16.100.1/32[V]   \
                                       0             Fa0/0      10.255.100.2


R4#show ip bgp vpnv4 all
BGP table version is 7, local router ID is 1.0.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65000:100 (default for vrf CUST_A)
 *>  10.255.100.0/24  0.0.0.0                  0         32768 ?
 *>i 10.255.200.0/24  1.0.5.1                  0    100      0 ?
 *>  172.16.100.1/32  10.255.100.2             2         32768 ?
 *>i 172.16.200.1/32  1.0.5.1                  2    100      0 ?

R0#sh mpls interfaces
Interface              IP            Tunnel   BGP Static Operational
FastEthernet0/0        Yes (ldp)     No       No  No     Yes
Ethernet1/0            Yes (ldp)     No       No  No     Yes
Ethernet1/1            Yes (ldp)     No       No  No     Yes
Ethernet1/2            Yes (ldp)     No       No  No     Yes

R0#sh mpls ldp neighbor
    Peer LDP Ident: 1.0.1.1:0; Local LDP Ident 1.0.0.1:0
        TCP connection: 1.0.1.1.37347 - 1.0.0.1.646
        State: Oper; Msgs sent/rcvd: 49/48; Downstream
        Up time: 00:25:44
        LDP discovery sources:
          Ethernet1/0, Src IP addr: 10.255.0.2
        Addresses bound to peer LDP Ident:
          10.255.0.201    1.0.1.1         10.255.0.2      10.255.0.13
          10.255.0.29
    Peer LDP Ident: 1.0.4.1:0; Local LDP Ident 1.0.0.1:0
        TCP connection: 1.0.4.1.61015 - 1.0.0.1.646
        State: Oper; Msgs sent/rcvd: 48/47; Downstream
        Up time: 00:25:32
        LDP discovery sources:
          FastEthernet0/0, Src IP addr: 10.255.0.102
        Addresses bound to peer LDP Ident:
          10.255.0.102    1.0.4.1         10.255.0.106
    Peer LDP Ident: 1.0.3.1:0; Local LDP Ident 1.0.0.1:0
        TCP connection: 1.0.3.1.63449 - 1.0.0.1.646
        State: Oper; Msgs sent/rcvd: 47/48; Downstream
        Up time: 00:25:32
        LDP discovery sources:
          Ethernet1/2, Src IP addr: 10.255.0.26
        Addresses bound to peer LDP Ident:
          10.255.0.205    1.0.3.1         10.255.0.6      10.255.0.14
          10.255.0.26
    Peer LDP Ident: 1.0.2.1:0; Local LDP Ident 1.0.0.1:0
        TCP connection: 1.0.2.1.27082 - 1.0.0.1.646
        State: Oper; Msgs sent/rcvd: 48/48; Downstream
        Up time: 00:25:31
        LDP discovery sources:
          Ethernet1/1, Src IP addr: 10.255.0.10
        Addresses bound to peer LDP Ident:
          10.255.0.105    1.0.2.1         10.255.0.5      10.255.0.10
          10.255.0.30

MPLS EoMPLS

R4#sh run int e 1/3

interface Ethernet1/3
 xconnect 1.0.5.1 200 encapsulation mpls
end

R4#sh mpls l2transport binding
  Destination Address: 1.0.5.1,VC ID: 200
    Local Label:  400
        Cbit: 1,    VC Type: Ethernet,    GroupID: 0
        MTU: 1500,   Interface Desc: n/a
        VCCV: CC Type: CW [1], RA [2], TTL [3]
              CV Type: LSPV [2], BFD/Raw [5]
    Remote Label: 500
        Cbit: 1,    VC Type: Ethernet,    GroupID: 0
        MTU: 1500,   Interface Desc: n/a
        VCCV: CC Type: CW [1], RA [2], TTL [3]
              CV Type: LSPV [2], BFD/Raw [5]

R4#sh mpls l2transport vc 200

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Et1/3          Ethernet                   1.0.5.1         200        UP



Add a Comment

Your email address will not be published. Required fields are marked *


CAPTCHA Image
Reload Image