LAB IV ( vPC – virtual Port-channels )

ComponentDescription
vPC Domain Includes the vPC Peers, KeepAlive Links and the PortChannels that use the vPC technology.
vPC Peer SwitchThe other switch within the vPC domain. Each switch is connected via the vPC peer link. Its also worth noting that one device is selected as primary and the other secondary.
vPC Member PortPorts included within the vPCs.
vPC Peer Keepalive LinkConnects both vPC peer switches and carries monitoring traffic to/from each peer switch. Monitoring is performed to ensures the switch(s) is both operational and running vPC.
vPC Peer LinkConnects both vPC peer switches. And carries BPDUs, HSRPs, and MAC addresses to its vPC peer. In the event of vPC member port failure it also carries unicast traffic to the peer switch.
Orphan PortAn orphan port is a port that is configured with a vPC VLAN (i.e a VLAN that is carried over the vPC peer link) and is not configured as a vPC member port.

A virtual PortChannel (vPC) allows links that are physically connected to two different Cisco Nexus™ 5000 Series devices to appear as a single PortChannel to a third device. The third device can be a Cisco Nexus 2000 Series Fabric Extender or a switch, server, or any other networking device. A vPC can provide Layer 2 multipathing, which allows you to create redundancy by increasing bandwidth, enabling multiple parallel paths between nodes and load-balancing traffic where alternative paths exist.

After you enable the vPC function, you create a peer keepalive link, which sends heartbeat messages between the two vPC peer devices.

The vPC domain includes both vPC peer devices, the vPC peer keepalive link, the vPC peer link, and all the PortChannels in the vPC domain connected to the downstream device. You can have only one vPC domain ID on each device.

#ENABLING VPC

vrf context VPC-VRF
feature VPC
vpc domain 100
  peer-keepalive destination 10.1.1.1 source 10.1.1.2 vrf VPC-VRF
#VPC PEER-LINK

interface Ethernet1/1
  description Peerlink
  switchport mode trunk
  channel-group 200 mode active
interface Ethernet1/2
  description Peerlink
  switchport mode trunk
  channel-group 200 mode active
interface port-channel200
  description vPC Peerlink
  vrf member VPC-VRF
  vpc peer-link
#VPC KEEP-ALIVE

interface Ethernet1/47
  description Keepalive
  no switchport
  channel-group 300 mode active
interface Ethernet1/48
  description Keepalive
  no switchport
  channel-group 300 mode active
interface port-channel400
  description Keepalive
  vrf member VPC-VRF
  no switchport
  ip address 10.1.1.1/30


# Nexus01
interface gi0/30
 channel-group 30
 interface po30
 vpc 30
# Nextus02
interface gi0/30
 channel-group 30 
 interface po30
 vpc 30

Add a Comment

Your email address will not be published. Required fields are marked *


CAPTCHA Image
Reload Image